Instalando LINE en Ubuntu

LINE es una alternativa japonesa a los servicios de chat móvil, y concretamente al más conocido Whatsapp. Como japonés que es no podían faltar los iconos totalmente absurdos de estética manga, que además aparecen en una modalidad de “stickers” que se insertan en el chat a un tamaño más grande que los emoticonos normales.

Una característica interesante de LINE en comparación con Whatsapp es que permite las llamadas gratuitas de voz (estaría por tanto más cerca de la funcionalidad de Viber, por ejemplo) y además que podemos instalar un cliente en nuestro PC para poder usar el servicio de chat sin tener que estar pendientes de nuestro móvil en todo momento.

Por desgracia sólo hay clientes oficiales para Windows y Mac, pero Wine viene al rescate de los usuarios de Linux.

En primer lugar tendremos que descargar el instalador de LINE desde la página oficial:

http://dl.desktop.line.naver.jp/naver/LINE/win/LineInst.exe

La versión de Wine que tenemos en los repositorios de Ubuntu 12.10 (wine 1.4) dará error al intentar instalar LINE dicendo algo como que no es posible instalar el programa porque ya está corriendo, y que lo cierres antes de intentar instalarlo.

Tendremos que actualizar Wine a la versión 1.5 desde un PPA:

sudo apt-add-repository ppa:ubuntu-wine/ppa

Actualizamos la información de los repositorios:

sudo apt-get update

Y actualizamos el Wine:

sudo apt-get dist-upgrade

Ya podemos instalar el LINE:

wine LineInst.exe

Una vez instalado (sólo hay que pulsar siguiente-siguiente… hasta terminar) se abrirá automáticamente y deberemos hacer login con la cuenta que hayamos creado con la aplicación LINE del móvil, usando la dirección de correo como usuario.

Y listo.

 [Actualización]

Parece que en Ubuntu 12.10 algún update más o menos reciente (no se si de Wine o de Line, que también ha recibido actualizaciones) hace que al abrir Line después de haberlo instalado provoque este error:

"Unhandled exception: privileged instruction in 32-bit code"

Como solución provisional el programa funcionará si desinstalas Wine1.5 y reinstalas Wine1.4 (después de haber instalado Line, ya que Wine1.5 sigue siendo necesario para que no falle la instalación):

sudo apt-get remove wine1.5
sudo apt-get install wine1.4

 

  • Jose

    Muchas gracias. Pensaba que no lo podría hacer funcionar con wine :-).

  • Victor De Vierna Amigo

    Funciona perfectamente, me gusta mucho esta pagina, es de gran ayuda. Gracias!!

  • Mike de Linares

    Holas! Yo lo he intentado un par de veces y me da mensaje The program cannot be installed because LINE is currently running… aunque no este andando en el movil ni en ningun otro lado… Alguna idea!?

    • Ese error despista porque no se debe realmente a que Line esté corriendo, es un fallo al ejecutarse en versiones anteriores de Wine.

      Comprueba que tu versión de Wine esté actualizada, yo lo tengo funcionando con la 1.5.20.

      • HectorOses

        Siiii, despues de hacer estoy y luego volver a Wine1.4 funciona.
        Muchas gracias

  • ismipi

    Va perfecto. Gracias por tu aportación

  • Rubén Díaz-Jorge

    Muchas gracias por la info!
    Yo también tenía el problema de que no wine no encontraba el LineInst.exe.
    Bajé LineInst.exe de la web de line y lo puse en la carpeta de system32.

  • Pingback: Install ‘Line’ on Ubuntu | Fon's blog()

  • luis

    lo he instalado pero al abrirse da un error grave y cierra line y wine

  • David

    Tengo Wine 1.4.1 he hecho todo lo que dice aquí para actualizar Wine a la versión 1.5, pero cuando voy a actualizar Wine con: “sudo apt-get dist-upgrade” me dice: “0 actualizados, 0 se instalarán, 0 para eliminar y 0 no actualizados.” y efectivamente Wine no se me actualiza y sigo ni poder abrir LINE. ¿Que pasa? ¿Que tengo que hacer?

    • ¿Qué versión de Ubuntu tienes? En la 12.10 debería funcionar con el repositorio PPA del artículo, y en la 13.04 viene de serie ya la versión 1.5. En versiones anteriores de Ubuntu no puedo asegurar que esté.

      Si tienes instalado el programa Synaptic puedes mirar en “Configuración->Repositorios->Otro software” y confirmar que efectivamente se ha añadido correctamente el PPA de Wine, y posteriormente darle en Synaptic al botón de “Recargar” y comprobar que no te da ningún error durante la actualización de las listas de paquetes.

    • elguindilla

      Eso me pasaba a mí también, prueba con esto, a mí me funcionó:
      sudo apt-get install wine1.5

  • Judit Estebanell

    Hola,

    Tengo un problema con el Line, mi versión de Ubuntu és 12.04 y actualizé el wine a la versión 1.5. Instalé el line sin problemas, pero no me deja abrir el archivo, me dice que hay un problema grave. He estado buscando en la web del wine pero no encuentro nada, alguien sabe que le puede pasar? Muchas gracias!

    • Hola,

      Si tienes el mismo problema que Waltrapax en la respuesta de arriba (no se encuentra la librería gnome-keyring-pkcs11.so en Ubuntu de 64 bits) pruedes probar a bajar la versión de la librería para Ubuntu 12.04 que he puesto arriba y copiarla a /usr/lib/i386-linux-gnu/pkcs11

      Saludos!

  • Waltrapax

    Hola,

    al igual que Judit el problema es que tenemos la versión de 64bits y wine no carga el modulo de

    gnome-keyring-pkcs11.so al buscarlo para LINE en 32bits, he intentado crear un enlace al

    gnome-keyring-pkcs11.so de 64 pero no he conseguido nada????????????????????

    • Buenas,

      No tengo ningún Ubuntu x86_64 para probar. Si quieres intentar solucionarlo, las librerías .so que necesitas para esa arquitectura son éstas (habría que colocarlas en la ruta donde busca las librerías de 32 bits obviamente, NO reemplazar las de 64 que ya están instaladas):

      Ubuntu 12.04: http://ubuntuone.com/33bNur1XI6nqhiaSRuROPR
      Ubuntu 12.10: http://ubuntuone.com/051pWss3ZpanEHCYkXteGD

      Al parecer es un problema conocido con el paquete gnome-keyring en Ubuntu.

      Si puedes probarlo y te funciona, cuéntanos!

      Saludos!

      • Timse

        Hola! Yo no tengo ese error en Ubuntu 12.10 x64, aunque he probado lo que propones, sin éxito. En mi caso el error que da wine es: “Unhandled exception: privileged instruction in 32-bit code (0x7de5510a).”, así que no sé si el problema es cargar el modulo que decís, u otra cosa. ¿Alguien lo ha hecho funcionar en 64bits?
        Gracias!

      • Waltrapax

        Lo había probado, gracias, ya ví el bug. Ahora el error es el mismo que
        le da a Timse. Estoy probando a instalarlo igual que el whatsapp sobre
        android a ver si funciona. Ya os contaré.

        Salu2.

  • Mortadaelo

    No puedo ejecutarlo en Xubuntu 12.04 de 64 bits. El error es “Unhandled exception: privileged instruction in 32-bit code (0x7de5510a).” pero no se que debo hacer con las soluciones que habéis aportado.

    La ruta /usr/lib/i386-linux-gnu/pkcs11 no encuetro el pkcs11. No se que debo hacer con la librerias que decis. Alguien lo consiguió hacer funcionar en 64 bits???

  • lrs

    Una vez instalado, cuando lo ejecuto el resultado es un aviso de error:
    “Cannot find winspool.drv. Please, re-install this application” ¿A alguien le pasa?

  • Lucasl

    Yo uso ubuntu de 32 bits y tengo este error “Unhandled exception: privileged instruction in 32-bit code”.
    ¿Alguna solución?
    Saludos!

  • jbartolo

    Yo tengo el mismo problema que Lucasl y Waltrapax. Lo instala bien, pero al ejecutarlo me dice: “Unhandled exception: privileged instruction in 32-bit code (0x7dce610a).” y luego hace un dump de varias cosas.

    ¿Alguien ha encontrado una solución a eso?

    • Parece que bien la última actualización de Wine o la de Line han fastiado el programa en Ubuntu 12.10 y ahora da ese infame error “Unhandled exception: privileged instruction in 32-bit code”.

      De momento la “solución” que he encontrado es que después de instalar el Line con Wine1.5 como indica el artículo (para evitar el error durante la instalación) desinstales Wine1.5 e instales Wine1.4. No se si con esa versión de Wine es 100% funcional pero de momento me abre el programa y me funciona el chat, no he probado más.

      En Ubuntu 13.04 por otra parte sigue siendo perfectamente funcional con el Wine1.5 (aunque aquí es 1.5.23 mientras que en 12.10 con el PPA es 1.5.26).

      • waltrapax

        Perfecto Caipirinha, funciona!! thanks

  • jbartolo

    Muchas gracias Caipirinha, ya está, ya me funciona 🙂

    Lo que he hecho es instalar con wine 1.5 y luego hacer un downgrade al wine 1.4 para ejecutar

  • wilow

    Esto es una p……. locura ,por qué no hacen la version LINUX totalmente operativa?

  • Ey, felicidades, muy buena entrada, me ha ayudado bastante sobre todo con la actualización que pusiste al final de Ubuntu 12.10
    Pasate cuando gustes a mi blog en http://www.michelle.slmx.org

  • David Escalante

    En crossover funciona de maravilla.

  • Qcho

    Gracias segui los pasos al pie de la letra en ubuntu 13.04 y ya tengo funcionando perfectamente line

  • Solo me dice que LINE se está ejecutando, y que “nanay”…. 😛

  • Luis

    Muchas gracias, pude instalar Line en Ubuntu 13.04 y esta funcionando bien

  • Wilberth Bencomo

    no me deja al ultimo pasa me sale que no se encontro el lineinst en sistem32 alguna ayuda